Help:Visual Editor

From UBC Wiki
Jump to: navigation, search

Opening the visual editor

To edit a page using the visual editor, click on the "Edit" tab at the top of the page. It may take a few seconds for the page to open for editing, and longer if the page is very long.

Clicking on the "Edit source" tab will open the classic wikitext source editor.

Getting started: the visual editor's toolbar

The visual editor's toolbar appears at the top of the screen when you begin editing. It includes some familiar icons: visual editor bar

Undo and Redo

Undo and Redo the changes you have made. VisualEditor - Toolbar - Undo-redo.png

Headings pulldown menu

Headings pull-down menu: allows you to change how the paragraph is formatted. To change the style of a paragraph, put your cursor in the paragraph and select an item in this menu (you don't have to highlight any text). Section titles are formatted "Heading", and subsections are "Heading 2", "Heading 3", and so on. The normal format for text is "Paragraph". VisualEditor Toolbar Headings-en.png

Formatting

Formatting: Pressing the "A" opens a menu.

  • The "Bold" item (B) bolds the selected text.
  • The "Italic" item (I) italicizes the selected text.
  • The "Superscript" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly higher than the surrounding text.
  • The "Subscript" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly lower than the surrounding text.
  • The "Strikethrough" item (S) adds a solid bar through the selected text.
  • The "Computer code" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • The "Underline" item (U) adds a solid line beneath the selected text.
  • The "Language" item (文A) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "Remove", removes all character formatting from the selected text, including links.

If you have not selected any text, then when you press the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located. VisualEditor Toolbar Formatting-en.png

Linking tool

Linking tool: The chain icon is the linking tool. Clicking on it (usually after selecting some text) opens the link dialog.

VisualEditor - Toolbar - Linking.png

Cite menu

Cite menu: The "Cite" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to basic reference formatting and the ability to reuse citations by using this menu. It also gives users quick access to local citation templates, if these are enabled on their wiki.

VisualEditor - Cite Pulldown.png

List and indentation

Lists and indentation: The first two items allow you to format text as either a "Bullet list" or a "Numbered list". The last two items allow you to decrease or increase the indentation level of list items. VisualEditor Toolbar Lists and indentation-en.png

Insert

Visual editor - insert menu.png

Insert:

  • The "Media" icon (a picture of mountains) opens the media dialog.
  • The "Template" icon (a puzzle piece) allows you to edit templates.
  • The "Table" item allows you to insert a table.
  • The "Comment" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode, where they are indicated by an exclamation mark icon. In edit mode, clicking on the exclamation mark icon allows you to edit or delete the comment.

The "Your signature" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.

  • The "Gallery" icon (a set of photos) allows you to insert a gallery to the page.

The "Chemical formula" icon opens the chemical formula inserter dialog.

  • The "Math formula" icon (Σ) opens the math formula inserter dialog.
  • The "References list" icon (three books) opens a dialog in which you can specify where references will be displayed to the reader. Usually this needs to be done only once on a page.

Special Character

Special character insertion: The "Special character" (Ω) icon is next to the "Insert" menu. When pressed, it displays a dialog showing many special characters. By pressing on a specific character, you place it into the text. These special characters include some standard symbols, diacritics, and mathematical symbols.

Page option menu

VisualEditor More Settings-en.png

The Page options menu is to the left of the Publish changes button. On this menu there are options to adjust page settings, such as whether the page is a redirect, or how it is indexed; to add, edit, or delete categories.

Switching to wikitext

When you click on the pencil icon - it will allow you to switch to source editing (wikitext) mode.

Publishing Changes

When you are finished editing, press the blue "Publish changes" button in the toolbar. If you have made no changes, the button will be disabled (grayed out). To cancel all your editing changes, close your browser window, or press the "Read" tab above the edit toolbar.

VisualEditor toolbar actions-en.png

Pressing the blue "Publish changes" button opens a dialog. You can then enter a brief summary of your actions, mark your edit as minor, and/or add the page to your Watchlist. The box for the summary is the equivalent of the Summary (?): field in the wikitext editor. You can also review your changes using the "Review your changes" button to confirm that they will function as intended before saving your changes. This is similar to the "Show changes" button in the wikitext editor.

The "Resume editing" button returns you to the page you were editing. You can publish all of your changes later.

VisualEditor save dialog-en.png

Adding Math/Chemical Formula

VisualEditor Formula Insert Menu-en.png

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and press on the "Math formula" icon ("Σ") in the "Insert" menu on the toolbar. If you want to add chemical formula, press on the "Chemical Formula" icon instead.

VisualEditor formula-en.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, press the "Done" button.

VisualEditor - editing existing mathematical formula.png

To edit an existing formula on the page, press on it and then press on the "Σ" icon that appears. This will open up the formula window, where you make changes.

Editing Categories

VisualEditor category item-en.png

To edit categories, on the "Page options" menu, press the "Categories" item.

VisualEditor category editing-en.png

Pressing on "Categories" opens a dialog that lists existing categories and allows you to add new ones, and to delete existing categories.

VisualEditor - Category editing 2.png

To remove an existing category, press on it and press on the "Remove" icon (trash can) in the dialog that opens. Pressing on a category also allows you to specify a sorting key for that specific category. Such a sorting key overrides the default sorting key.

Press "Apply changes" when you're done editing categories to return to the page editor.