STEP-BY-STEP INSTRUCTIONS TO CONTROL OPTROTRAK FROM MATLAB ON A 64-BIT WINDOWS PLATFORM
March 2016 – Michele Touchette – The University of British Columbia
This method uses a modified version of that found on motorbehaviour.wordpress.com, which was originally described for 32-bit platforms. The advantage of using 64-bit Windows is increased access to RAM for memory-intensive Matlab programs.
C++ code and Matlab scripts are written by Jarrod Blinch - November 2010 – University of Lethbridge
Purpose: 
To describe step-by-step how to control the Optotrak Certus (without the Optotrak Data Acquisition Unit (ODAU)) through Matlab without having to use the Optotrak software, a TCP/IP server, or Matlab’s Instrument Control Toolbox. This method makes use of C++ MEX files that call Optotrak’s API. These MEX files are called in Matlab.
Note: This method can be used with Optotrak 3020, however I have not tested this myself. There is also C++ code included for Optotrak with the ODAU but, again, I have not tested this myself.
Requirements:
· Host computer with 64-bit Windows OS (I am using Windows 7)
· Optrotrak camera & System Control Unit (SCU) connect to host computer via NDI’s USB module
· Optotrak API (purchase from NDI)
· Matlab 32-bit (I am using 2014)
· Visual Studio - Check your Matlab version to see which version of Visual Studio you require for that edition (I am using 2013)

Steps:
These steps are copied from the document found on motorbehaviour.wordpress.com; however modified or corrected steps are in bold.

· Install an Optotrak USB Module and connect it to the Optotrak system control unit (SCU)
· Purchase this USB Module from NDI
· Install Microsoft Visual Studio (Check mathworks.com for version required with your Matlab edition; I used Visual Studio 2013 with Matlab 2014 32-bit)
· Free download from Microsoft
· Visual C++ is no longer included in Visual Studio earlier versions. To avoid a strange error message, you need to download the C++ components for Visual Studio if they aren’t included in your version. The following directions are, perhaps, the easiest way to do this:
· Navigate to Control Panel > Programs and Features
· Select “Microsoft Visual Studio Community 2015” (for example; it might be a different year) and click Change and a Visual Studio window will open
· Click Modify
· Under Programming Languages check off Visual C++ , which will also select the sub-items
· Click UPDATE and the need C++ components will install
· Install Optroak API
· Purchase from NDI
· Use the default installation paths (C:\NDIoapi, C:\ndigital)
· Install Matlab
· You may be entitled to a student discount if you buy it from your University store
· Create a MEX project in Visual C++
· Open Visual Studio 2013
· Navigate to File > New > Project…
· Select Installed > Templates > Visual C++ > Win32 > Win32 Project
· Name the project:  Matlab_to_Optotrak
· Click OK and the Win32 Application Wizard will appear
· Click Next > and then select DLL and check Empty project
· Click Finish
· Navigate to Project > Add New Item…
· Select Header File (.h)
· Name the file:  Matlab_to_Optotrak.def
· Click Add
· Enter the following in the new file:
LIBRARY “Matlab_to_Optotrak”
EXPORTS mexFunction
This definition file (*.def) tells the compiler and linker that mexFunction should be accessible from outside.  In other words, Matlab will be able to call mexFunction.
· Navigate to Project > Add New Item…
· Select C++ File (.cpp)
· Name the file:  mexFunction.cpp
· Click Add
· Navigate to Project > Add Existing Item…
· Navigate to the Optotrak API msvc directory with *.lib files. In some cases, the .lib files are dispersed in different folders. You can copy and paste them all into the msvc folder.
· For me, it is C:\NDIoapi\ndlib\msvc
· Select both nditb.lib and oapi.lib and click Add
· Navigate to File > Save All
· Click on Matlab _to_Optotrak in the Solution Explorer
· The Solution Explorer should be the right pane of Visual C++
· Selecting Matlab_to_Optotrak will ensure the properties we need to change are available (the next steps)
· Navigate to Project > Matlab_to_Optotrak Properties…
· Select Configuration Properties > Debugging > Environment
· Click the column beside Environment, click the down arrow, and then <Edit...>
· Enter: PATH=%PATH%;C:\NDIoapi\dll\
· Select C/C++ > General > Additional Include Directories
· Click the column beside Additional Include Directories, click the down arrow, and then <Edit…>
· Click on the New Folder icon and a new line will appear
· Click on the … of the new line
· Navigate to the Matlab include directory
· For me, it is C:\Program Files\MATLAB\R2014b\extern\include
· Click Select Folder
· Click on the New Folder icon and a new line will appear
· Click on the … of the new line
· Navigate to the Optotrak realtime directory
· For me, it is C:\ndigital\realtime
· Click Select Folder
· Click on the New Folder icon and a new line will appear
· Click on the … of the new line
· Navigate to the Optotrak API include directory with *.h files; in some cases the *.h files are dispersed in different folders. Find them all (there should be four – ndtypes.h, ndpack.h, ndopto.h, and ndhost.h) and copy/paste them into the ‘include’ folder: 
· For me, it is C:\NDIoapi\ndlib\include
· Click Select Folder and then OK again to be back at the Properties window
· Select C/C++ > Preprocessor > Preprocessor Definitions
· Click the down arrow beside Preprocessor definitions and select <Edit…>
· Add MATLAB_MEX_FILE to the bottom of the list 
· Add PLATFORM_X86 on a new line
· [bookmark: _GoBack]Click OK
· Select Linker > General > Output File
· Click the down arrow and then <Edit...>
· Change the Output File to:  $(OutDir)\Matlab_to_Optotrak.mexw32
· Click ok
· Select Linker > General > Additional Library Directories
· Click the down arrow and select <Edit…>
· Click on the New Folder icon and a new line will appear
· Click on the … of the new line
· Navigate to the Matlab windows directory
· For me, it is C:\Program Files\MATLAB\R2014b\extern\lib\win32\microsoft
· Click Select Folder and then OK to be back at the Properties window
· Select Linker > Input > Additional Dependencies
· Click the down arrow and select <Edit…>
· Add libmat.lib, libmex.lib, and libmx.lib on new lines and click OK
· Select Linker > Input > Module Definition File
· Click the down arrow and select <Edit…>
· Enter:  Matlab_to_Optotrak.def 
· Click OK
· Click OK to close the Properties window
· Navigate to File > Save All
These steps ensure the MEX function can be compiled and linked by Visual C++ and then called from within Matlab.  The main output will be Matlab_to_Optotrak.mexw32, which will soon have the function mexFunction that can be called by Matlab.  If you get lost in the process, there are some pictures in the tutorial Using C/C++ under Matlab (Part 2) (http://comisef.wikidot.com/tutorial:using-c-c-under-matlab-part-2 ).  Another tutorial (Walkthrough: Creating and Using a Dynamic Link Library [C++], http://msdn.microsoft.com/en-us/library/ms235636.aspx ) explains the steps required for the MEX function to call the Optotrak API.
· Add the following text to mexFunction.cpp and then Save All
#include "mex.h"

void mexFunction(int nlhs, mxArray *plhs[], int nrhs, mxArray *prhs[]) {
return;
}

· Select Build > Build Solution
· In the Output at the bottom, it should say Build:  1 succeeded…
· You can ignore the warnings about non-ascii characters and the output filename
· If not, read the error statements (which are cryptic) to correct the problem
· Test the mexFunction in Matlab
· Open Matlab
· Change the Matlab path to the location of Matlab_to_Optotrak.mexw32 file
· For me, it is C:\Users\Administrator2\My Documents\Visual Studio 2015\Projects\Matlab_to_Optotrak\Debug
· Create a new *.m file and then save it as hello_optotrak.m in the current path
· Add in this one command, Matlab_to_Optotrak() , and run the file
Although no output was produced, Matlab just successfully called the mexFunction (which doesn’t do anything yet) and then returned control to Matlab.  Next, we will have the mexFunction initialize the Optotrak and return a message of success or failure to Matlab.
· Close Matlab
· You cannot build the mexFunction in C++ while Matlab is accessing Matlab_to_Optotrak.mexw32
· Instead of closing Matlab, you can run ‘clear mex’ in Matlab to release the Matlab_to_Optotrak.mexw32 file
· Go back to mexFunction.cpp and update it as follows
#include "mex.h"

#include "ndtypes.h"
#include "ndpack.h"
#include "ndopto.h"

void mexFunction(int nlhs, mxArray *plhs[], int nrhs, mxArray *prhs[]) {
	int
		return_code;

	// This will cause the Optotrak SCU to beep twice.
	return_code = TransputerLoadSystem("system");
	nlhs = 2;
	plhs[0] = mxCreateDoubleScalar(return_code);
	
	if (return_code != 0) {
		plhs[1] = mxCreateString("TransputerLoadSystem: Failed");
		TransputerShutdownSystem();
		return;
	}
		
	plhs[1] = mxCreateString("TransputerLoadSystem: Success");
	TransputerShutdownSystem();
return;
}

· Navigate to Build > Build Solution
When mexFunction is now called from Matlab, it will attempt to load the Optotrak.  The return code and a message will be return by mexFunction to Matlab.  If you would like more information on how to code MEX files, I recommend Writing MATLAB C/MEX Code ( http://www.mathworks.com/matlabcentral/fileexchange/27151-writing-matlab-cmex-code ).  For more information on the Optrotrak API, refer to the manual Optotrak Application Porgrammer’s Interface Guide.
Before rerunning hello_optotrak.m in Matlab, ensure the Optotrak camera and SCU are on and the computer you are using is connected to the SCU.  Make sure everything is turned off if you need to rewire the Optotrak.  Open Matlab, change the path to the location of the hello_optotrak.m and run hello_optotrak.m
[ return_code message ] = Matlab_to_Optotrak()

If everything worked, then you should have heard two beeps from the SCU and then received a return code of 0 and the message TransputerLoadSystem: Success.  Congratulations, you just controlled the Optotrak from Matlab!
If that didn’t work, then here are a few troubleshooting tips.  If the Optotrak SCU didn’t beep at all, then there is likely a communication issue from your computer to the SCU.  The most likely problem is the cable between the two is not connected properly.  A return code of 1000 and a Failed message indicates the computer is talking to the Optotrak but something went wrong.  Check that C:\ndigital\realtime is one of the Additional Include Directories in Visual C++ so the Optotrak can find the system.nif file.  It is also possible that the system.nif file is out of date and is trying to configure the Optotrak in an impossible way, for example, looking for the ODAU on the wrong port.  To update the system.nif file, run optset32.exe under C:\ndigital\programs .  If you still have problems, you can compare the system.nif file on the Matlab computer to the system.nif file on the computer you normally use to control the Optotrak.  Errors this early usually indicate that the hardware isn’t connected properly.
Unfortunately, problems at this step are hard to diagnose because Optotrak doesn’t yet create an error log.  Messages and errors for later API function calls will be added to opto.err in the same directory as hello_optotrak.m. This blog post may also help, https://motorbehaviour.wordpress.com/2015/02/24/controlling-optotrak-from-matlab-ii/
The next steps involve growing the mexFunction to allow for all sorts of calls to the Optotrak API from Matlab.  One option is to pass the name of the API function (with any parameters) from Matlab to the mexFunction.  The mexFunction will simply identify which API function you want to call, pass along the parameters, and return a message of success or failure to Matlab.  Then we can build a program in Matlab that will initiailize the Optotrak, collect data, convert data, and display the results.
This code is available in the attached mexFunction.cpp and collect_a_trial.m.  You will also need open_ndi_bin_file.m to run collect_a_trail.m.  Copy and paste mexFunction.cpp into C++ and build it.  Now copy collect_a_trail.m into the same folder as hello_optotrak.m, open matlab, change the path to the location of collect_a_trial.m, and run it.  I’ve also copied and pasted the code for the three files below.

collect_a_trial.m
% Written by Jarrod Blinch, November 13th, 2010
% Available from motorbehaviour.wordpress.com
 
clear all;
 
collection_num_markers = 3;     % optotrak
collection_num_channels = 0;    % odau
collection_frequency = 100;     % Hz
collection_duration = 5;        % s
 
[a b] = Matlab_to_Optotrak('TransputerLoadSystem', collection_num_markers, collection_frequency, collection_duration); %#ok<NASGU>
if (a ~= 0)
    error('TransputerLoadSystem died!');
end
[a b] = Matlab_to_Optotrak('OptotrakActivateMarkers'); %#ok<NASGU>
if (a ~= 0)
    error('OptotrakActivateMarkers died!');
end
 
[a b] = Matlab_to_Optotrak('DataBufferInitializeFile', '', '001.P01');
 
disp('start')
% Array b will contain the current IRAD locations.
[a b] = Matlab_to_Optotrak('DataGetLatest3D');
display('IRED locations:');
display(b(4:end));
 
% Array d will contain the current ODAU input.
% [c d] = Matlab_to_Optotrak('DataGetLatestOdauRaw');
% display('ODAU signals:');
% display(d(4:end));
 
 
[a b] = Matlab_to_Optotrak('DataBufferStart');
 
data_buffer_done = false;
while (data_buffer_done == false)
    [a b] = Matlab_to_Optotrak('DataBufferWriteData');
    if (a ~= 0)
        display('Warning: DataBufferWriteData died!');
    end
    if (b == 1)
        data_buffer_done = true;
    end
    
    % Can be used to peek at the data during collection.
    [a b] = Matlab_to_Optotrak('DataGetLatest3D');
%     [c d] = Matlab_to_Optotrak('DataGetLatestOdauRaw');
end
disp('done')
 
% Convert the R and O files to C and V.
[a b] = Matlab_to_Optotrak('FileConvert', '', '001.P01');
 
optotrak_array = open_ndi_bin_file('C#001.P01');
% odau_array = open_ndi_bin_file('V1#001.P01');
 
figure;
hold on;
title('IRED locations');
plot3(optotrak_array(:,1), optotrak_array(:,2), optotrak_array(:,3), 'r');
plot3(optotrak_array(:,4), optotrak_array(:,5), optotrak_array(:,6), 'g');
plot3(optotrak_array(:,7), optotrak_array(:,8), optotrak_array(:,9), 'b');
 
% figure;
% hold on;
% title('ODAU signals');
% plot(odau_array);
 
[a b] = Matlab_to_Optotrak('OptotrakDeActivateMarkers'); %#ok<NASGU>
if (a ~= 0)
    display('Warning: OptotrakDeActivateMarkers died!');
end
[a b] = Matlab_to_Optotrak('TransputerShutdownSystem');
if (a ~= 0)
    display('Warning: TransputerShutdownSystem died!');
end
 
% Release the Matlab_to_Optotrak.mexw32 file, which allows it
% to be compiled in Visual C++ if needed.
clear mex;


open_ndi_bin_file.m
% [ndi_array] = open_ndi_bin_file(filename)
%
% Written by Jarrod Blinch, November 6th, 2010
% Available from motorbehaviour.wordpress.com
function [ndi_array] = open_ndi_bin_file(filename)
 
 
fid = fopen(filename, 'r');
fread(fid, 1, 'char');                      % 32
item_total = fread(fid, 1, 'short');        % items per frame
subitem_total = fread(fid, 1, 'short');     % subitems per frame
column_total = item_total * subitem_total;
frame_total = fread(fid, 1, 'int');         % number of frames
fread(fid, 1, 'float');                     % collection frame frequency
fread(fid, 60, 'char=>char');               % user comments
fread(fid, 60, 'char=>char');               % system comments
fread(fid, 30, 'char=>char');               % file description
fread(fid, 1, 'short');                     % cutoff filter frequency
fread(fid, 8, 'char=>char');                % time of collection
fread(fid, 1, 'short');                     % unused?
fread(fid, 8, 'char=>char');                % date of collection
fread(fid, 73, 'char');                     % extended headed and unused
 
ndi_array = ones(frame_total,column_total) .* NaN;
for frame_num = 1:frame_total
    for column_num = 1:column_total
        data = fread(fid, 1, 'float');
        if (data < -100000) % technically, it is EE EE EE EE or -3.697314e+28
            data = NaN;
        end
        ndi_array(frame_num,column_num) = data;
    end
end
 
fclose(fid);
 
end


mexFunction.cpp [with an Optotrak Data Acquisition Unit (ODAU)]
// Written by Jarrod Blinch, November 13th, 2010
// Available from motorbehaviour.wordpress.com
#include "mex.h"

#include <matrix.h>
#include <string.h>
#include <windows.h>
#include <math.h>

#include "ndtypes.h"
#include "ndpack.h"
#include "ndopto.h"

void mexFunction(int nlhs, mxArray* plhs[], int nrhs, mxArray* prhs[]) {
	int
		return_code;
	unsigned int
		uRealtimeDataReady = 0,
		uSpoolComplete = 0,
		uSpoolStatus = 0,
		uFrameNumber,
		uElements,
		uFlags,
		ui,
		uj;
	static int
		puRawData[3+1];		// number of ODAU channels + 1
	static Position3d
		p3dData[1];
	char
		StrBuffer[65],
		StrBuffer2[65],
		StrBuffer3[65],
	    filename_input[68],
		filename_output[68];
        //szNDErrorString[MAX_ERROR_STRING_LENGTH + 1];	// 2047 + 1 (ndopto.h)
	double
		*y,
		dk,
		dl;


	// Make sure there is only one argument.
	if (nrhs < 1) {
		mexErrMsgTxt("At least one string argument must be passed!\n");
	}

	// Make sure the argument is a string.
	if (!mxIsChar(prhs[0])) {
		mexErrMsgTxt("The first argument should be a string!\n");
	}

	// Read the string into StrBuffer.
	if (mxGetString(prhs[0], StrBuffer, sizeof(StrBuffer)-1)) {
		mexErrMsgTxt("Unable to read the argument string!\n");
	}


	if (strcmp(StrBuffer, "TransputerDetermineSystemCfg") == 0) {
		// This will beep twice.
		return_code = TransputerLoadSystem( "system" );
		
		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("TransputerDetermineSystemCfg");
	} else if (strcmp(StrBuffer, "TransputerLoadSystem") == 0) {
		// Ensure we have a second and third integer arguments (optotrak markers, odau channels).
	    if (nrhs != 5) {
			mexErrMsgTxt("Four additional arguments (#markers, #channels, hz, time) must be passed with TransputerLoadSystem!\n");
	    }

	    // Make sure the second and third arguments are unsigned integers.
	    if (!mxIsDouble(prhs[1])) {
			mexErrMsgTxt("The second argument (num oprotrak markers) should be an unsigned integer!\n");
	    }
		if (!mxIsDouble(prhs[2])) {
			mexErrMsgTxt("The third argument (num odau channels) should be an unsigned integer!\n");
	    }
		if (!mxIsDouble(prhs[3])) {
		    mexErrMsgTxt("The fourth argument (colection frequency) should be a double!\n");
	    }
		if (!mxIsDouble(prhs[4])) {
		    mexErrMsgTxt("The fifth argument (collection duration) should be a double!\n");
	    }
		
		// Read the second and third arguments into unsigned integers.
		ui = (unsigned int)mxGetScalar(prhs[1]);	// number of Optotrak markers
		uj = (unsigned int)mxGetScalar(prhs[2]);	// number of ODAU1 channels
		dk = mxGetScalar(prhs[3]);					// collection frequency
		dl = mxGetScalar(prhs[4]);					// collection duration (s)

		// This will beep twice.
		return_code = TransputerLoadSystem( "system" );
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("TransputerLoadSystem");
			TransputerShutdownSystem();
			return;
		}

		return_code = TransputerInitializeSystem(OPTO_LOG_ERRORS_FLAG | OPTO_LOG_MESSAGES_FLAG);
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("TransputerInitializeSystem");
			TransputerShutdownSystem();
			return;
		}

		return_code = OptotrakLoadCameraParameters("standard");
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("OptotrakLoadCameraParameters");
			TransputerShutdownSystem();
			return;
		}

		return_code = OdauSetupCollection(
			ODAU1,					// nOdauId ODAU1
			uj,						// nChannels (1-256)
			1,						// nGain
			ODAU_DIGITAL_PORT_OFF,	// nDigitalMode ODAU_DIGITAL_PORT_OFF
			(float)dk,				// fFrameFrequency (1-100000)
			(float)50000.0,			// fScanFrequency (1-100000)
			1,						// nStreamData
			(float)dl,				// fCollectionTime in seconds
			(float)0.0,				// fPreTriggerTime, not supported and must be 0 
			0);						// uFlags
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("OdauSetupCollection");
			TransputerShutdownSystem();
			return;
		}

		return_code = OptotrakSetStroberPortTable(ui, 0, 0, 0);	// Number of markers connected to each port
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("OptotrakSetStroberPortTable");
			TransputerShutdownSystem();
			return;
		}

		return_code = OptotrakSetupCollection(
            ui,						// Number of markers in the collection
            (float)dk,				// Frequency to collect data frames at
            (float)2500.0,			// Marker frequency for marker maximum on-time
            30,						// Dynamic or Static Threshold value to use
            160,					// Minimum gain code amplification to use
            1,						// Stream mode for the data buffers
            (float)0.35,			// Marker Duty Cycle to use
            (float)7.0,				// Voltage to use when turning on markers
            (float)dl,				// Number of seconds of data to collect
            (float)0.0,				// Number of seconds to pre-trigger data by, not suppoted and must be 0
            OPTOTRAK_NO_FIRE_MARKERS_FLAG | OPTOTRAK_BUFFER_RAW_FLAG);	// OPTOTRAK_GET_NEXT_FRAME_FLAG often used with realtime data
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("OptotrakSetupCollection");
			TransputerShutdownSystem();
			return;
		}

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("OptotrakSetupCollection");
	} else if (strcmp(StrBuffer, "TransputerShutdownSystem") == 0) {
		return_code = TransputerShutdownSystem();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("TransputerShutdownSystem");
	} else if (strcmp(StrBuffer, "OptotrakActivateMarkers") == 0) {
		return_code = OptotrakActivateMarkers();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("OptotrakActivateMarkers");
	} else if (strcmp(StrBuffer, "OptotrakDeActivateMarkers") == 0) {
		return_code = OptotrakDeActivateMarkers();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("OptotrakDeActivateMarkers");
    } else if (strcmp(StrBuffer, "DataBufferInitializeFile") == 0) {
		// Second argument example: ../data/raw/
		// Third argument example: 001.P1
		// The program will append R# or O1#
		
		// Ensure we have a second and third string argument with the filename (path, part of filename).
	    if (nrhs != 3) {
		    mexErrMsgTxt("A second and third string arguments must also be passed with DataBufferInitializeFile!\n");
	    }

	    // Make sure the second and third arguments are strings.
	    if (!mxIsChar(prhs[1])) {
		    mexErrMsgTxt("The second filepath argument should be a string!\n");
	    }
		if (!mxIsChar(prhs[2])) {
		    mexErrMsgTxt("The third part-filename argument should be a string!\n");
	    }

	    // Read the strings into StrBuffers.
	    if (mxGetString(prhs[1], StrBuffer2, sizeof(StrBuffer2)-1)) {
		    mexErrMsgTxt("Unable to read second filepath argument string!\n");
	    }
		if (mxGetString(prhs[2], StrBuffer3, sizeof(StrBuffer3)-1)) {
		    mexErrMsgTxt("Unable to read third part-filename argument string!\n");
	    }

		filename_input[0] = '\0';
		strcat_s(filename_input, StrBuffer2);
		strcat_s(filename_input, "R#");
		strcat_s(filename_input, StrBuffer3);
		return_code = DataBufferInitializeFile(OPTOTRAK, filename_input);
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("DataBufferInitiazeFile OPTOTRAK");
			return;
		}

		filename_input[0] = '\0';
		strcat_s(filename_input, StrBuffer2);
		strcat_s(filename_input, "O1#");
		strcat_s(filename_input, StrBuffer3);
        return_code = DataBufferInitializeFile(ODAU1, filename_input);

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("DataBufferInitializeFile ODAU1");
	} else if (strcmp(StrBuffer, "DataBufferStart") == 0) {
		return_code = DataBufferStart();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("DataBufferStart");
	} else if (strcmp(StrBuffer, "DataBufferWriteData") == 0) {
		// Returns -1 and DataBufferWriteData || uSpoolStatus on error.
		// Returns 0 and uSpoolComplete on success.	
        return_code = DataBufferWriteData(&uRealtimeDataReady, &uSpoolComplete, &uSpoolStatus, NULL);

		nlhs = 2;
		if (return_code != 0 || uSpoolStatus != 0) {
			plhs[0] = mxCreateDoubleScalar(-1);
			if (return_code != 0) {
				plhs[1] = mxCreateString("DataBufferWriteData");
			} else {
				plhs[1] = mxCreateString("uSpoolStatus");
			}
		} else {
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateDoubleScalar(uSpoolComplete);
		}
	} else if (strcmp(StrBuffer, "FileConvert") == 0) {
		// Ensure we have a second and third string argument with the filename (path, part of filename).
	    if (nrhs != 3) {
		    mexErrMsgTxt("A second and third string arguments must also be passed with DataBufferInitializeFile!\n");
	    }

	    // Make sure the second and third arguments are strings.
	    if (!mxIsChar(prhs[1])) {
		    mexErrMsgTxt("The second filepath argument should be a string!\n");
	    }
		if (!mxIsChar(prhs[2])) {
		    mexErrMsgTxt("The third part-filename argument should be a string!\n");
	    }

	    // Read the strings into StrBuffers.
	    if (mxGetString(prhs[1], StrBuffer2, sizeof(StrBuffer2)-1)) {
		    mexErrMsgTxt("Unable to read second filepath argument string!\n");
	    }
		if (mxGetString(prhs[2], StrBuffer3, sizeof(StrBuffer3)-1)) {
		    mexErrMsgTxt("Unable to read third part-filename argument string!\n");
	    }

		filename_input[0] = '\0';
		filename_output[0] = '\0';
		strcat_s(filename_input, StrBuffer2);
		strcat_s(filename_output, StrBuffer2);
		strcat_s(filename_input, "R#");
		strcat_s(filename_output, "C#");
		strcat_s(filename_input, StrBuffer3);
		strcat_s(filename_output, StrBuffer3);
		return_code = FileConvert(filename_input, filename_output, OPTOTRAK_RAW);
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("FileConvert OPTOTRAK");
			//OptotrakGetErrorString(szNDErrorString, MAX_ERROR_STRING_LENGTH + 1);
			//mexPrintf("API Error: %s", szNDErrorString);	% printed weird text...
			return;
		}

		filename_input[0] = '\0';
		filename_output[0] = '\0';
		strcat_s(filename_input, StrBuffer2);
		strcat_s(filename_output, StrBuffer2);
		strcat_s(filename_input, "O1#");
		strcat_s(filename_output, "V1#");
		strcat_s(filename_input, StrBuffer3);
		strcat_s(filename_output, StrBuffer3);
        return_code = FileConvert(filename_input, filename_output, ANALOG_RAW);

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("FileConvert ODAU");
	} else if (strcmp(StrBuffer, "DataGetLatest3D") == 0) {
		//(float)-3.0E28
		return_code = DataGetLatest3D(&uFrameNumber, &uElements, &uFlags, p3dData);
		if (return_code != 0) {
		    plhs[1] = mxCreateString("DataGetLatest3D");
		} else {
			// Send back frame number, elements, and raw data in a float array.
			plhs[1] = mxCreateDoubleMatrix(1, (uElements * 3) + 3, mxREAL);
			y = mxGetPr(plhs[1]);
			y[0] = (double)uFrameNumber;
			y[1] = (double)uElements;
			y[2] = (double)uFlags;

			for (ui = 1; ui <= uElements; ui++) {
				uj = ui * 3;

				y[uj] = (double)p3dData[ui-1].x;
				y[uj+1] = (double)p3dData[ui-1].y;
				y[uj+2] = (double)p3dData[ui-1].z;
			}
		}

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
	} else if (strcmp(StrBuffer, "DataGetLatestOdauRaw") == 0) {
		return_code = DataGetLatestOdauRaw(ODAU1, &uFrameNumber, &uElements, &uFlags, puRawData);
	    if (return_code != 0) {
		    plhs[1] = mxCreateString("DataGetLatestOdauRaw");
		} else {
			// Send back frame number, elements, and raw data in a float array.
			plhs[1] = mxCreateDoubleMatrix(1, uElements + 3, mxREAL);
			y = mxGetPr(plhs[1]);
			y[0] = (double)uFrameNumber;
			y[1] = (double)uElements;
			y[2] = (double)uFlags;

			for (ui = 1; ui <= uElements; ui++) {
				y[ui+2] = (double)((int)(puRawData[ui-1])) * 0.000305175 / (float)1;	// final divide is ODAU gain
			}
		}

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
	} else {
		mexErrMsgTxt("A command was not found for that string argument!\n");
	}

}


mexFunction.cpp [for an Optotrak Certus without an Optotrak Data Acquisition Unit (ODAU)]
// Written by Jarrod Blinch, August 2015
// Available from motorbehaviour.wordpress.com
#include "mex.h"

#include <matrix.h>
#include <string.h>
#include <windows.h>
#include <math.h>

#include "ndtypes.h"
#include "ndpack.h"
#include "ndopto.h"



void mexFunction(int nlhs, mxArray* plhs[], int nrhs, mxArray* prhs[]) {
	int
		return_code;
	unsigned int
		uRealtimeDataReady = 0,
		uSpoolComplete = 0,
		uSpoolStatus = 0,
		uFrameNumber,
		uElements,
		uFlags,
		ui,
		uj;
	static int
		puRawData[3 + 1];		// number of ODAU channels + 1
	static Position3d
		p3dData[1];
	char
		StrBuffer[65],
		StrBuffer2[65],
		StrBuffer3[65],
		filename_input[68],
		filename_output[68];
	//szNDErrorString[MAX_ERROR_STRING_LENGTH + 1];	// 2047 + 1 (ndopto.h)
	double
		*y,
		dk,
		dl;



	// Make sure there is only one argument.
	if (nrhs < 1) {
		mexErrMsgTxt("At least one string argument must be passed!\n");
	}

	// Make sure the argument is a string.
	if (!mxIsChar(prhs[0])) {
		mexErrMsgTxt("The first argument should be a string!\n");
	}

	// Read the string into StrBuffer.
	if (mxGetString(prhs[0], StrBuffer, sizeof(StrBuffer) - 1)) {
		mexErrMsgTxt("Unable to read the argument string!\n");
	}


	if (strcmp(StrBuffer, "TransputerDetermineSystemCfg") == 0) {
		// This will beep twice.
		return_code = TransputerLoadSystem("system");

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("TransputerDetermineSystemCfg");
	}
	else if (strcmp(StrBuffer, "TransputerLoadSystem") == 0) {
		// Ensure we have a second and third integer arguments (optotrak markers, odau channels).
		if (nrhs != 4) {
			mexErrMsgTxt("Three additional arguments (#markers, Hz, time) must be passed with TransputerLoadSystem!\n");
		}

		// Make sure the arguments are as expected.
		if (!mxIsDouble(prhs[1])) {
			mexErrMsgTxt("The second argument (num oprotrak markers) should be an unsigned integer!\n");
		}
		if (!mxIsDouble(prhs[2])) {
			mexErrMsgTxt("The third argument (colection frequency) should be a double!\n");
		}
		if (!mxIsDouble(prhs[3])) {
			mexErrMsgTxt("The fourth argument (collection duration) should be a double!\n");
		}

		// Read the second and third arguments into unsigned integers.
		ui = (unsigned int)mxGetScalar(prhs[1]);	// number of Optotrak markers
		dk = mxGetScalar(prhs[2]);					// collection frequency
		dl = mxGetScalar(prhs[3]);					// collection duration (s)

													// This will beep twice.
		return_code = TransputerLoadSystem("system");
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("TransputerLoadSystem");
			TransputerShutdownSystem();
			return;
		}

		return_code = TransputerInitializeSystem(OPTO_LOG_ERRORS_FLAG | OPTO_LOG_MESSAGES_FLAG);
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("TransputerInitializeSystem");
			TransputerShutdownSystem();
			return;
		}
		
		return_code = OptotrakLoadCameraParameters("standard");
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("OptotrakLoadCameraParameters");
			TransputerShutdownSystem();
			return;
		}

		return_code = OptotrakSetStroberPortTable(ui, 0, 0, 0);	// Number of markers connected to each port
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("OptotrakSetStroberPortTable");
			TransputerShutdownSystem();
			return;
		}

		return_code = OptotrakSetupCollection(
			ui,						// Number of markers in the collection
			(float)dk,				// Frequency to collect data frames at
			(float)2500.0,			// Marker frequency for marker maximum on-time
			30,						// Dynamic or Static Threshold value to use
			160,					// Minimum gain code amplification to use
			1,						// Stream mode for the data buffers
			(float)0.35,			// Marker Duty Cycle to use
			(float)7.0,				// Voltage to use when turning on markers
			(float)dl,				// Number of seconds of data to collect
			(float)0.0,				// Number of seconds to pre-trigger data by, not suppoted and must be 0
			OPTOTRAK_NO_FIRE_MARKERS_FLAG | OPTOTRAK_BUFFER_RAW_FLAG);	// OPTOTRAK_GET_NEXT_FRAME_FLAG often used with realtime data
		if (return_code != 0) {
			nlhs = 2;
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateString("OptotrakSetupCollection");
			TransputerShutdownSystem();
			return;
		}

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("OptotrakSetupCollection");
	}
	else if (strcmp(StrBuffer, "TransputerShutdownSystem") == 0) {
		return_code = TransputerShutdownSystem();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("TransputerShutdownSystem");
	}
	else if (strcmp(StrBuffer, "OptotrakActivateMarkers") == 0) {
		return_code = OptotrakActivateMarkers();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("OptotrakActivateMarkers");
	}
	else if (strcmp(StrBuffer, "OptotrakDeActivateMarkers") == 0) {
		return_code = OptotrakDeActivateMarkers();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("OptotrakDeActivateMarkers");
	}
	else if (strcmp(StrBuffer, "DataBufferInitializeFile") == 0) {
		// Second argument example: ../data/raw/
		// Third argument example: 001.P1
		// The program will append R#

		// Ensure we have a second and third string argument with the filename (path, part of filename).
		if (nrhs != 3) {
			mexErrMsgTxt("A second and third string arguments must also be passed with DataBufferInitializeFile!\n");
		}

		// Make sure the second and third arguments are strings.
		if (!mxIsChar(prhs[1])) {
			mexErrMsgTxt("The second filepath argument should be a string!\n");
		}
		if (!mxIsChar(prhs[2])) {
			mexErrMsgTxt("The third part-filename argument should be a string!\n");
		}

		// Read the strings into StrBuffers.
		if (mxGetString(prhs[1], StrBuffer2, sizeof(StrBuffer2) - 1)) {
			mexErrMsgTxt("Unable to read second filepath argument string!\n");
		}
		if (mxGetString(prhs[2], StrBuffer3, sizeof(StrBuffer3) - 1)) {
			mexErrMsgTxt("Unable to read third part-filename argument string!\n");
		}

		filename_input[0] = '\0';
		strcat_s(filename_input, StrBuffer2);
		strcat_s(filename_input, "R#");
		strcat_s(filename_input, StrBuffer3);
		return_code = DataBufferInitializeFile(OPTOTRAK, filename_input);
		
		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("DataBufferInitiazeFile OPTOTRAK");
	}
	else if (strcmp(StrBuffer, "DataBufferStart") == 0) {
		return_code = DataBufferStart();

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("DataBufferStart");
	}
	else if (strcmp(StrBuffer, "DataBufferWriteData") == 0) {
		// Returns -1 and DataBufferWriteData || uSpoolStatus on error.
		// Returns 0 and uSpoolComplete on success.	
		return_code = DataBufferWriteData(&uRealtimeDataReady, &uSpoolComplete, &uSpoolStatus, NULL);

		nlhs = 2;
		if (return_code != 0 || uSpoolStatus != 0) {
			plhs[0] = mxCreateDoubleScalar(-1);
			if (return_code != 0) {
				plhs[1] = mxCreateString("DataBufferWriteData");
			}
			else {
				plhs[1] = mxCreateString("uSpoolStatus");
			}
		}
		else {
			plhs[0] = mxCreateDoubleScalar(return_code);
			plhs[1] = mxCreateDoubleScalar(uSpoolComplete);
		}
	}
	else if (strcmp(StrBuffer, "FileConvert") == 0) {
		// Ensure we have a second and third string argument with the filename (path, part of filename).
		if (nrhs != 3) {
			mexErrMsgTxt("A second and third string arguments must also be passed with DataBufferInitializeFile!\n");
		}

		// Make sure the second and third arguments are strings.
		if (!mxIsChar(prhs[1])) {
			mexErrMsgTxt("The second filepath argument should be a string!\n");
		}
		if (!mxIsChar(prhs[2])) {
			mexErrMsgTxt("The third part-filename argument should be a string!\n");
		}

		// Read the strings into StrBuffers.
		if (mxGetString(prhs[1], StrBuffer2, sizeof(StrBuffer2) - 1)) {
			mexErrMsgTxt("Unable to read second filepath argument string!\n");
		}
		if (mxGetString(prhs[2], StrBuffer3, sizeof(StrBuffer3) - 1)) {
			mexErrMsgTxt("Unable to read third part-filename argument string!\n");
		}

		filename_input[0] = '\0';
		filename_output[0] = '\0';
		strcat_s(filename_input, StrBuffer2);
		strcat_s(filename_output, StrBuffer2);
		strcat_s(filename_input, "R#");
		strcat_s(filename_output, "C#");
		strcat_s(filename_input, StrBuffer3);
		strcat_s(filename_output, StrBuffer3);
		return_code = FileConvert(filename_input, filename_output, OPTOTRAK_RAW);
		
		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
		plhs[1] = mxCreateString("FileConvert OPTOTRAK");
		//OptotrakGetErrorString(szNDErrorString, MAX_ERROR_STRING_LENGTH + 1);
		//mexPrintf("API Error: %s", szNDErrorString);	% printed weird text...
	}
	else if (strcmp(StrBuffer, "DataGetLatest3D") == 0) {
		//(float)-3.0E28
		return_code = DataGetLatest3D(&uFrameNumber, &uElements, &uFlags, p3dData);
		if (return_code != 0) {
			plhs[1] = mxCreateString("DataGetLatest3D");
		}
		else {
			// Send back frame number, elements, and raw data in a float array.
			plhs[1] = mxCreateDoubleMatrix(1, (uElements * 3) + 3, mxREAL);
			y = mxGetPr(plhs[1]);
			y[0] = (double)uFrameNumber;
			y[1] = (double)uElements;
			y[2] = (double)uFlags;

			for (ui = 1; ui <= uElements; ui++) {
				uj = ui * 3;

				y[uj] = (double)p3dData[ui - 1].x;
				y[uj + 1] = (double)p3dData[ui - 1].y;
				y[uj + 2] = (double)p3dData[ui - 1].z;
			}
		}

		nlhs = 2;
		plhs[0] = mxCreateDoubleScalar(return_code);
	}
	else {
		mexErrMsgTxt("A command was not found for that string argument!\n");
	}

}


